Archive

Posts Tagged ‘wireless’

AirPort Legacy Wireless (Archive)

May 4th, 2009 No comments

Note: This article was transferred from my original blog.

Note: The older application ‘AirPort Utility for Graphite and Snow’ is not compatible with Mac OS X 10.6 “Snow Leopard”.


So months ago I upgraded to a new D-Link Wireless N router. Finally with everything setup, things worked great. One problem though, I setup my new router using a WPA encryption code instead of WEP in order to use the 802.11n standard as told to me by the manual.

So what few older devices that didn’t support WPA and only WEP could no longer connect to the internet. This didn’t seem like much of a problem… at first. I soon discovered the two devices that couldn’t go online anymore… my TiVo and my first generation Nintendo DS. The TiVo saw the network with my Linksys USB 802.11g adapter, but yelled at me to buy a TiVo Wireless brand adapter to use WPA encrypted signals. I kid you not!

As for the Nintendo DS, unlike the Wii, it only supports WEP encryption. The same with the Nintendo DS Lite, now the new Nintendo DSi fixes this issue and supports WPA… but ONLY on new games that support WPA. That’s right, older titles work work through a WPA standard even though the system supports it. God that’s just plain stupid.

So anyway I had a problem, the TiVo and DS couldn’t connect. Up until recently I’ve been running an extra long ethernet cord to the TiVo every 2 weeks to update it’s TV programing guide and listings. Well now that I got the AC adapter for this old Apple AirPort router (Graphite 802.11b) I’m back in business. So I setup the old Graphite AirPort station, I plugged it into my Mac and tried to connect to it wirelessly, but it’s old info was still on there and it was locked with a password. So I reset the router with a paper clip in the reset hole for 30 seconds and I was good to go. The only problem is configuring the device, according to Apple online you need to use a crossover ethernet cable, or have your Mac and the AirPort connected both to a hub or a switch (even a hub or a switch of a router) via regular ethernet cables. Apparently it won’t work wirelessly. But, to do this I needed to download an older version of the Apple AirPort Utility (called ‘AirPort Admin Utility for Graphite and Snow’, Wow, what a mouth full…).

So I downloaded that from Apple here. I was then able to see the AirPort, but I kept getting errors when trying to configure it. So I was about ready to think the AirPort base station was busted, I mean after all spending $3 in total for it, not too bad if it’s just broken.

BUT! Then I did a little googling. It turns out, if you’re using an Intel-based Mac and running Mac OS X “Leopard” 10.5.2 or later, you MUST run the Apple AirPort Utility in Rosetta mode! (Apple article here) So I selected the ‘AirPort Admin Utility for Graphite and Snow’ in the Utilities folder of my Applications folder, selected Get Info and checked the ‘Open using Rosetta’ box. Boom, worked perfectly! I would of NEVER of guessed to check that. (Warning!: This version of the AirPort Utility is not compatible with Mac OS X 10.6 “Snow Leopard”, it will not launch!)

After this things ran very smoothly. I updated the firmware on the base station to the latest version, and I set it up to work with my old router, the two are connected through an ethernet cable. Now my little Graphite AirPort base station is being put to good use, and is sending out compatible wireless signals to the “outdated” devices in my house. Yay!

-Steven

Categories: General Tags: , , , , , ,